Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 12 months ago. Apr 09, 2016 - 15:13 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 12 months ago. Apr 09, 2016 - 15:09 EDT