Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 19, 2017 - 09:33 EDT
Identified
We are currently looking at issues with Paladins PC.
Posted 3 months ago. Apr 19, 2017 - 09:12 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 3 months ago. Apr 19, 2017 - 09:10 EDT
This incident affected: Paladins PC.