Smite Console Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 19 days ago. Oct 29, 2018 - 20:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 19 days ago. Oct 29, 2018 - 17:39 EDT
Update
We are continuing to investigate this issue.
Posted 19 days ago. Oct 29, 2018 - 17:18 EDT
Update
We are continuing to investigate this issue.
Posted 19 days ago. Oct 29, 2018 - 17:17 EDT
Investigating
We are investigating a possible issue with #Smite #PS4 and #Xbox
Posted 19 days ago. Oct 29, 2018 - 17:16 EDT
This incident affected: Smite (Smite PS4).