Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 18, 2016 - 06:11 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted over 1 year ago. Feb 18, 2016 - 06:00 EST