Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 13, 2016 - 01:57 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted almost 2 years ago. Feb 13, 2016 - 01:49 EST