Emergency Restart Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart of #Smite #PC has been completed.
Posted 5 months ago. Feb 01, 2017 - 13:12 EST
Investigating
We will be performing an emergency restart of #Smite #PC
Posted 5 months ago. Feb 01, 2017 - 12:48 EST
This incident affected: Smite PC - North America / Europe.