Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This smite pc incident has been resolved. #smite
Posted almost 2 years ago. Mar 11, 2016 - 03:06 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted almost 2 years ago. Mar 10, 2016 - 23:44 EST