Paladins Strike Log in issues
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Paladins #Strike log in issue has been resolved.
Posted 6 months ago. May 14, 2018 - 16:50 EDT
Monitoring
We have been able to isolate and resolve the log in issues. We will continue to monitor
Posted 6 months ago. May 14, 2018 - 15:58 EDT
Identified
We are currently investigating an issue that is impacting logins while using your Hi-Rez account credentials.
Posted 6 months ago. May 14, 2018 - 15:09 EDT
This incident affected: Paladins Strike (Paladins Strike Mobile).