Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
the #Smite PS4 environment has returned to normal; apologies for the inconvenience
Posted 12 months ago. Jun 09, 2016 - 16:23 EDT
Monitoring
#Smite PS4 encountered a brief issue with match making and player logins; we have identified the issue and implemented a fix; logins should be returning to normal and we are monitoring the situation
Posted 12 months ago. Jun 09, 2016 - 16:09 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 12 months ago. Jun 09, 2016 - 15:56 EDT