Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart of #Paladins PC has been completed.
Posted 9 months ago. Sep 30, 2017 - 09:31 EDT
Identified
We are going to perform an emergency restart of #Paladins PC in 15 minutes.
Posted 9 months ago. Sep 30, 2017 - 08:52 EDT
This incident affected: Paladins (Paladins PC).