Realm Royale Matchmaking
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 11, 2018 - 21:46 EDT
Monitoring
We were able to address the issue affecting matchmaking. Players should be able to login and queue for matches. We will continue to monitor for any further issues.
Posted about 1 year ago. Aug 11, 2018 - 21:01 EDT
Identified
There is an issue affect matchmaking on Realm Royale. We are working to address the issue.
Posted about 1 year ago. Aug 11, 2018 - 20:53 EDT
This incident affected: Realm Royale (Realm Royale PC).