Limiting Logins Paladins Xbox
Incident Report for Hi-Rez Studios, Inc
Resolved
The #paladins #xbox restart has been completed
Posted 7 months ago. Mar 01, 2017 - 17:18 EST
Identified
We will be restarting the environment to resolve back-end server issues.
We apologize for the inconvenience.
Posted 7 months ago. Mar 01, 2017 - 15:00 EST
Investigating
We will be limiting logins for a short amount of time on #paladins #xbox.
Posted 7 months ago. Mar 01, 2017 - 14:54 EST
This incident affected: Paladins Xbox.