Smite PC Match Making Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 08, 2018 - 17:02 EDT
Monitoring
The Fix has been implemented. We are continuing to monitor.
Posted 3 months ago. Jul 08, 2018 - 15:53 EDT
Identified
We are temporarily pausing logins so we can implement a fix for the issue.
Posted 3 months ago. Jul 08, 2018 - 15:47 EDT
Investigating
We are investigating the issue affecting Queues on Smite PC
Posted 3 months ago. Jul 08, 2018 - 15:44 EDT
This incident affected: Smite (Smite PC).