Smite PS4 Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have resumed logins for #Smite #PS4.
Posted 2 months ago. Jun 12, 2018 - 16:55 EDT
Investigating
We are temporarily limiting logins for #Smite #PS4 to investigate an issue.
Posted 2 months ago. Jun 12, 2018 - 16:43 EDT
This incident affected: Smite (Smite PS4).