Steam Issues with Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #SmitePC
Posted 13 days ago. Mar 14, 2017 - 08:58 EDT
Update
We are going to perform a quick restart of Smite PC # SmitePC
Posted 14 days ago. Mar 14, 2017 - 07:53 EDT
Investigating
We are currently looking into the Steam issues on Smite PC #smitepc
Posted 14 days ago. Mar 14, 2017 - 07:40 EDT
This incident affected: Smite PC - North America / Europe.