Rogue Company Matchmaking Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved and we are monitoring.
Posted Apr 16, 2021 - 15:31 EDT
Identified
We have identified an issue with #RogueCompany and are implementing a fix.
Posted Apr 16, 2021 - 15:16 EDT
Investigating
We are investigating an issue affecting #RogueCompany matches.
Posted Apr 16, 2021 - 14:22 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).