Realm Royale Matchmaking Issues
Incident Report for Hi-Rez Studios, Inc
Postmortem

Our infrastructure suffered a hardware failure resulting in taking our games offline, while we worked to isolate the problem. Infrastructure engineers worked quickly with vendors to isolate and correct the fault. The total duration for this event was 3.9 hours. All games are currently fully operational at this time and we apologize for any inconvenience this might have caused.

Thank you for your continued support

Warmest Regards,

The Hi-Rez Operations Team

Posted 7 days ago. Apr 16, 2019 - 14:45 EDT

Resolved
#RealmRoyale #PS4 is back up and running.
Posted 8 days ago. Apr 15, 2019 - 13:55 EDT
Update
We are still in the process of isolating this issue.
Posted 8 days ago. Apr 15, 2019 - 13:03 EDT
Update
We are still working on isolating the root cause of #RealmRoyale #PC, #PS4, & #Xbox issue.
Posted 8 days ago. Apr 15, 2019 - 12:30 EDT
Update
We are bringing #RealmRoyale #PC, #PS4, & #Xbox down at this time to further investigate this issue.
Posted 8 days ago. Apr 15, 2019 - 11:49 EDT
Investigating
We are currently investigating issues with #RealmRoyale #PC, #PS4, & #Xbox matchmaking.
Posted 8 days ago. Apr 15, 2019 - 11:40 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox).