Realm Royale Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 03, 2020 - 02:48 EDT
Investigating
We are performing an emergency restart on @RealmRoyale
Posted May 03, 2020 - 01:59 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).