Paladins PC Emergency Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
The restart of #Paladins PC is complete.
Posted 4 months ago. Apr 07, 2017 - 06:37 EDT
Monitoring
#Paladins PC is operational; we are continuing to monitor.
Posted 4 months ago. Apr 07, 2017 - 06:21 EDT
Investigating
Working to restart #Paladins PC; apologies for the inconvenience
Posted 4 months ago. Apr 07, 2017 - 06:09 EDT
This incident affected: Paladins PC.