Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency restart has been completed
Posted 4 months ago. Jun 16, 2017 - 14:57 EDT
Identified
We are performing an Emergency Restart of #Paladins #PC
Posted 4 months ago. Jun 16, 2017 - 14:50 EDT