Paladins XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 20, 2018 - 12:50 EDT
Investigating
Automated services have detected a possible problem with #Paladins XBOX. We are investigating.
Posted 4 months ago. Apr 20, 2018 - 12:10 EDT
This incident affected: Paladins (Paladins Xbox).