Smite PS4 Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
Connectivity to Smite on PS4 has been restored.
Sorry for the inconvenience.
#SMITE
Posted 12 months ago. Apr 07, 2016 - 20:12 EDT
Investigating
We are working to resolve the connectivity issues associated with smite PS4.
Sorry for the inconvenience.
#SMITE
Posted 12 months ago. Apr 07, 2016 - 19:57 EDT