Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
All HiRez products have recovered and are stable; #SMITE #Paladins #Tribes
Posted 4 months ago. Jan 29, 2017 - 17:35 EST
Monitoring
All products have returned to normal service; we are continuing to monitor; #SMITE #Paladins #Tribes
Posted 4 months ago. Jan 29, 2017 - 17:19 EST
Update
We are working to return all HiRez products to active service; all games should be back to normal soon. #SMITE #Paladins #Tribes
Posted 4 months ago. Jan 29, 2017 - 17:03 EST
Identified
We have identified an issue which is impacting all HiRez products; we are working to resolve. #SMITE #Paladins #Tribes
Posted 4 months ago. Jan 29, 2017 - 16:48 EST
Investigating
Automated services have detected a possible discovery issue that may impact multiple games. We are investigating. #SMITE #Paladins
Posted 4 months ago. Jan 29, 2017 - 16:44 EST
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, Paladins PS4, Tribes Ascend, and Smite Tactics.