Tribes PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 7 months ago. Aug 30, 2016 - 10:11 EDT
Investigating
Automated services have detected a possible problem with #Tribes PC. We are investigating.
Posted 7 months ago. Aug 30, 2016 - 07:00 EDT