Paladins Console Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The #paladins #ps4 and #Xbox restart has been completed.
Posted 3 months ago. Mar 13, 2017 - 08:38 EDT
Investigating
We will be performing another restart of #Paladins on #PS4 and #Xbox
We apologize for the inconvenience.
Posted 3 months ago. Mar 13, 2017 - 08:17 EDT
This incident affected: Paladins Xbox and Paladins PS4.