Paladins PC Possible Log In Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 19 days ago. Aug 03, 2018 - 01:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 19 days ago. Aug 03, 2018 - 00:59 EDT
Investigating
We are currently investigating this issue.
Posted 19 days ago. Aug 03, 2018 - 00:53 EDT
This incident affected: Paladins (Paladins PC).