Nintendo Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 27, 2018 - 23:39 EDT
Identified
Nintendo services are still undergoing maintenance. It seems the maintenance time has been extended. Players may be unable to play Paladins on Switch during this time. If you wish to view the status of this maintenance, you may reference the Nintendo status page: https://www.nintendo.com/consumer/network/en_na/network_status.jsp
Posted 3 months ago. Aug 27, 2018 - 19:13 EDT
This incident affected: Paladins (Paladins Switch).