Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOX incident has been resolved. #smite
Posted 6 months ago. Nov 30, 2016 - 14:27 EST
Update
We are currently suspending logins for SMITE XBOX a few minutes#smite
Posted 6 months ago. Nov 30, 2016 - 14:21 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 6 months ago. Nov 30, 2016 - 14:18 EST