Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Dec 23, 2016 - 08:20 EST
Identified
We are currently looking into issues with #PALADINS PC.
Posted 5 months ago. Dec 23, 2016 - 07:57 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. Dec 23, 2016 - 07:42 EST
This incident affected: Paladins PC.