Unplanned XBOX Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
XBOX has been successfully restarted and the issues with acquisitions have been resolved.
#SMITE
Posted about 2 years ago. Oct 01, 2015 - 21:48 EDT
Investigating
We will be restarting the SMITE-XBOX environment to alleviate some issues players are experiencing with acquisitions.
#SMITE
Posted about 2 years ago. Oct 01, 2015 - 21:16 EDT