Realm Royale Crossplay & PS4 Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RealmRoyale #PC, #PS4, & #Xbox restart has been completed.
Posted 5 months ago. Apr 09, 2019 - 11:51 EDT
Identified
We are performing a #RealmRoyale #PC, #Xbox, & #PS4 restart. Limited logins have begun.
Posted 5 months ago. Apr 09, 2019 - 11:24 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox).