Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Hirez Games incident has been resolved #SMITE #Paladins #Tribes
Posted 9 months ago. Mar 22, 2017 - 22:40 EDT
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted 9 months ago. Mar 22, 2017 - 22:32 EDT
This incident affected: Smite PC - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, Paladins PS4, Smite Tactics PC, and Tribes Ascend.