All Games - Network Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
All traffic is back to normal; all Hi-Rez products stable.
Posted 6 months ago. Sep 22, 2016 - 12:54 EDT
Monitoring
Our upstream provider has mitigated the issue and all games are stabilizing; we are continuing to monitor the issue.
Posted 6 months ago. Sep 22, 2016 - 12:23 EDT
Update
The issue persists at this time; Hi-Rez is continuing to work with our upstream provider towards a resolution; again, players in Europe and Southeast Asia will see the most impact; more updates to follow.
Posted 6 months ago. Sep 22, 2016 - 11:23 EDT
Identified
The issue has been identified as connectivity problems with one of our upstream providers; the issue will most impact Hi-Rez users in Europe and Southeast Asia; we are working with our upstream provider to address.
Posted 6 months ago. Sep 22, 2016 - 10:30 EDT
Investigating
All Hi-Rez games are being impacted by intermittent network issues; we are investigating and working to resolve.
Posted 6 months ago. Sep 22, 2016 - 10:09 EDT