Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PC is now operating normally.
#SMITEPC
Posted about 1 year ago. Feb 08, 2016 - 15:24 EST
Identified
Matches are having issues starting, we are investigating the problem.
Posted about 1 year ago. Feb 08, 2016 - 15:10 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Feb 08, 2016 - 15:08 EST