We will be performing a restart of Hand Of the Gods
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 15 days ago. Jun 10, 2017 - 13:52 EDT
Investigating
We are performing an emergency restart of #HandOftheGods
Posted 15 days ago. Jun 10, 2017 - 13:39 EDT
This incident affected: Smite Tactics.