Smite PC/Switch/Xbox Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 11, 2019 - 15:39 EST
Investigating
We are currently investigating an issue with #Smite #PC, #Switch, & #Xbox logins.
Posted 6 months ago. Feb 11, 2019 - 14:18 EST
This incident affected: Smite (Smite PC, Smite Xbox).