Japan Paladins Latency
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 20 days ago. Sep 26, 2019 - 11:36 EDT
Investigating
Japan servers are experiencing latency issues, Operations is investigating.
Posted 20 days ago. Sep 26, 2019 - 10:03 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch).