Paladins Strike Server Issue.
Incident Report for Hi-Rez Studios, Inc
Resolved
The incident has been resolved with #PaladinsStrike
Posted about 1 month ago. Aug 20, 2019 - 11:56 EDT
Investigating
We are currently investigating an issue with #PaladinsStrike
Posted about 1 month ago. Aug 20, 2019 - 11:34 EDT
This incident affected: Paladins Strike (Paladins Strike Mobile).