Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins #PC issue has been resolved
Posted 22 days ago. Jul 27, 2017 - 06:45 EDT
Monitoring
Services are recovering and we are currently monitoring #Paladins #PC
Posted 22 days ago. Jul 27, 2017 - 06:34 EDT
Identified
We have identified an issue with #Paladins #PC and are working on bringing services back to normal
Posted 22 days ago. Jul 27, 2017 - 06:11 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 22 days ago. Jul 27, 2017 - 06:04 EDT
This incident affected: Paladins PC.