Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed and chat is working as normal. We are continuing to monitor.
Posted 7 months ago. Jan 06, 2018 - 15:35 EST
Monitoring
Logins have resumed.
Posted 7 months ago. Jan 06, 2018 - 15:26 EST
Investigating
We are looking into it and pausing logins temporarily.
Posted 7 months ago. Jan 06, 2018 - 15:17 EST
This incident affected: Smite (Smite PC).