Paladins PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. May 06, 2019 - 15:00 EDT
Monitoring
The game is back online. We will continue to monitor the game in the mean time.
Posted 4 months ago. May 06, 2019 - 14:43 EDT
Identified
We will be performing an emergency restart of Paladins PS4. The game will be back shortly.
Posted 4 months ago. May 06, 2019 - 14:23 EDT
This incident affected: Paladins (Paladins PS4).