Web Store Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite, #Paladins, and #HotG #PC web store issue has been resolved.
Posted 3 months ago. Sep 26, 2018 - 10:44 EDT
Monitoring
We have implemented a fix for the this issue and are monitoring the results.
Posted 3 months ago. Sep 26, 2018 - 10:23 EDT
Investigating
We are currently investigating issues with the web store for #Smite, #Paladins, and #HotG #PC.
Posted 3 months ago. Sep 26, 2018 - 10:10 EDT
This incident affected: Hi-Rez Studios (Hi-Rez Public APIs).