Smite PC Match Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 07, 2018 - 12:00 EDT
Monitoring
The fix has been implemented and we are keeping an eye on things.
Posted 4 months ago. Jul 07, 2018 - 11:42 EDT
Identified
We are temporarily pausing logins so we can implement a fix.
Posted 4 months ago. Jul 07, 2018 - 11:32 EDT
Investigating
We are investigating an issue affecting starting matches on #Smite #PC. We are looking into the issue.
Posted 4 months ago. Jul 07, 2018 - 11:30 EDT
This incident affected: Smite (Smite PC).