Smite PS4 Possible Issues with logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 23, 2016 - 19:03 EDT
Investigating
We are currently investigating login issues with smite on PS4.
#SMITE
Posted about 1 year ago. Mar 23, 2016 - 18:15 EDT