Smite PC Emergency Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Smite #PC has been resolved.
Posted 2 months ago. Jun 12, 2018 - 15:27 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jun 12, 2018 - 14:57 EDT
Identified
We will be bringing down #Smite PC in a moment for maintenance
Posted 2 months ago. Jun 12, 2018 - 13:37 EDT
This incident affected: Smite (Smite PC).