Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite XBOX issue has been resolved#smite
Posted about 1 year ago. Mar 07, 2016 - 02:21 EDT
Update
Haulting loggins in for the momment on Smite XBOX #Smite
Posted about 1 year ago. Mar 07, 2016 - 02:02 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Mar 07, 2016 - 01:57 EDT