Rogue Company Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jul 26, 2020 - 23:38 EDT
Investigating
Due to overwhelming demand, we are experiencing some issues with server stability and scalability with our new backend architecture. We apologize for any inconvenience that this may have caused.
Posted Jul 26, 2020 - 14:49 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).