Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart of #Paladins #PC has been completed.
Posted 15 days ago. Oct 07, 2017 - 03:52 EDT
Identified
We are performing an emergency restart of #Paladins #PC. The game will be back up shortly.
Posted 15 days ago. Oct 07, 2017 - 03:20 EDT
This incident affected: Paladins PC.