Smite PC - Limited Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 15, 2016 - 18:11 EDT
Investigating
#SMITE PC will be limiting logins briefly to address minor issue; apologies for the inconvenience
Posted over 1 year ago. Mar 15, 2016 - 17:10 EDT