Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOX incident has been resolved. #smite
Posted 10 months ago. Sep 07, 2016 - 21:20 EDT
Identified
Posted 10 months ago. Sep 07, 2016 - 20:52 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 10 months ago. Sep 07, 2016 - 20:48 EDT